Welcome! Log In Create A New Profile

Advanced

Trouble hashing certain files

Posted by 100PctGuapo 
Trouble hashing certain files
December 09, 2010 03:45AM
I'm running jUCy 0.85 on mac OSX 10.6. Some files just have problem hashing. There's no particular rhyme or reason as to why, but they just keep spitting errors. The files fail to hash, so when jUCy periodically scans my folders for new files, it sees these ones, thinks that they are unhashed, and then attempts to hash them, which in turn spits back the same error messages. When I add other files to my share, it hashes them successfully, then goes on to the problematic ones, and spits back the same error.
I attached the log:
Pastebin: Hashing errors on jUCy
Re: Trouble hashing certain files
December 09, 2010 11:43AM
It seems to fail to add the hashes of the files to the database. Possibly due to them being already there.
Its kind of strange.

What you could try is move the files away from the folder and then enter

/pruneHashes

in the hubwindow. This should delete any currently unused hashes..
Then move them back..

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: Trouble hashing certain files
December 09, 2010 11:48AM
I don't know what might cause this.
And can't find out with the given logs.
Please provide the logfile!

please see:

[jucy.eu]

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine



Edited 1 time(s). Last edit at 12/09/2010 11:50AM by Quicksilver.
Re: Trouble hashing certain files
February 29, 2012 03:05PM
Alright, now I have the log files. Still 0.85, still 10.6 (waiting for 10.8 at this point), Java 6 (1.6.0_29)

error.log

.metadata/.log (though this doesn't have much of interest

I've been having the same problems as before.
Re: Trouble hashing certain files
February 29, 2012 06:17PM
Somehow the database seems to be corrupted.

Did the pruneHashes before solve the problem for some time?
or didn't help it at all?

If your DownloadQueue is empty I would recomment you try to delete the whole database
/home/<username>/.UC/db folder
and see if the problem persits.
Its impossible to see what corrupted the database.
Yet there seems to be a problem with it. Did these problems start happening after a crash of jucy/ unclean shutdown?

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Sorry, only registered users may post in this forum.

Click here to login