Welcome! Log In Create A New Profile

Advanced

0.87.1 crashing on 10.10

Posted by iMiKE 
0.87.1 crashing on 10.10
November 26, 2015 12:24PM
Jucy 0.87.1 is crashing on MacOSX 10.10 in different times. There is no any rule when it crash.
Often when I'm moving table columns.

Logs are attached
error.log: [pastebin.ca]
metadata.log [pastebin.ca]



Edited 2 time(s). Last edit at 11/26/2015 12:37PM by iMiKE.
Re: 0.87.1 crashing on 10.10
November 26, 2015 03:25PM
Get a current Java version : [www.java.com] and check if the problem persists.

Your Java seems terribly outdated!

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: 0.87.1 crashing on 10.10
November 26, 2015 03:53PM
Nope, I'm currently running Java 1.8 Update 66.
Re: 0.87.1 crashing on 10.10
December 01, 2015 09:46PM
Your log said differently.
Please check by enterign java -version in the console this should print out the currently used version.
(The pastebin logs seem down... sry for my late reply... but I remember the logs showing outdated version numbers)

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine



Edited 1 time(s). Last edit at 12/01/2015 09:47PM by Quicksilver.
Re: 0.87.1 crashing on 10.10
December 02, 2015 01:31PM
java -version
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468-11M4833)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)
but java.com says I'm updated




Edited 1 time(s). Last edit at 12/02/2015 01:44PM by iMiKE.
Re: 0.87.1 crashing on 10.10
December 02, 2015 01:52PM
according to this [docs.oracle.com]
java -version command shows only jdk version and jre version may be differ from jdk

I have found 1.8 installation
bash-3.2$ /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)



Edited 1 time(s). Last edit at 12/02/2015 01:56PM by iMiKE.
Re: 0.87.1 crashing on 10.10
December 02, 2015 02:01PM
When entering java -version the currently running runtime environment your java executable, that you just called, belongs to, is printed out.

While it seems you have java 8 installed, from commandline your java 6 seems to be called instead. So there may be something wrong with your path settings.

Check out the following thread: [stackoverflow.com]

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine



Edited 2 time(s). Last edit at 12/02/2015 02:02PM by Quicksilver.
Re: 0.87.1 crashing on 10.10
December 02, 2015 02:51PM
Okay, I changed java_home from JDK 1.6 to JRE 1.8 as was in your link.
java -version
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)

but when I'm launching jucy, it shows me error message.
Does Jucy real needs JDK instead of JRE?
Re: 0.87.1 crashing on 10.10
December 02, 2015 05:03PM
It should not...

I must admit I am clueless what causes this.
Will it run if pointed to a jdk 1.8?

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: 0.87.1 crashing on 10.10
December 02, 2015 07:03PM
I installed JDK 1.8. Java -version shows this installation.
But Jucy won't start (need 1.6 as on scrren before).
I moved JDK 1.6 back, so I have 2 versions of JDK installed - 1.6 and 1.8 (java -verson shows 1.8).
Jucy starts. When I move 1.6 out, Jucy won't start. So, it uses 1.8 but without 1.6 won't start.

It's very strange. Jucy should use only JRE 1.8, not JDK.
Re: 0.87.1 crashing on 10.10
December 08, 2015 10:17AM
I can reproduce this now... and will have to release a fix for this as soon as I find out how.

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: 0.87.1 crashing on 10.10
December 08, 2015 02:14PM
To get Jucy to run on Java8 and Mac OSX 10.10: You will need a 64 bit version of jucy... this doesn't work with the 32 bit Version for me:


Copy the Info.plist file located at

/Library/Java/JavaVirtualMachines/jdk.1.8.<…>/Contents/

to your Desktop ...

and then replace
<key>JVMCapabilities</key>
 <array>
  <string>CommandLine</string>
 </array>

with the following:

<key>JVMCapabilities</key>
 <array>
  <string>JNI</string>
  <string>BundledApp</string>
  <string>CommandLine</string>
 </array>

Then copy it back to the former location (this needs admin rights).

Then you have to log out and log back in into your Mac / or reboot.
After you have done so you should be able to start Jucy (Security Settings might give you further hinderance System Prefs -> Security to allow Jucy to execute)

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine



Edited 2 time(s). Last edit at 12/08/2015 02:17PM by Quicksilver.
Re: 0.87.1 crashing on 10.10
December 08, 2015 05:19PM
I've removed JDK 1.6 and reproduced steps from your message.
Now Jucy 0.87.1 starts with only JDK1.8 well.
Here is Installation details from Jucy [pastebin.ca]
So, problem with starting on JDK was solved. But can you fix starting on JRE1.8 only? I think there is no need to have whole JDK installed for Jucy.
Re: 0.87.1 crashing on 10.10
December 08, 2015 05:37PM
This is a fix that needs to be provided by the framework Jucy is based on.
As long as they don't fix it there is no fix for Jucy in reasonable time. (Except bundling a jre with Jucy)

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: 0.87.1 crashing on 10.10
December 08, 2015 05:39PM
So, needing JDK instead of JRE it is bug in Java?
Re: 0.87.1 crashing on 10.10
December 09, 2015 10:24AM
It is a bug in the Eclipse RCP launcher.
It may be this problem ended up there as bug due to changes in Java8 that make it not backwards compatible.
At least this fix with changeing the Info.plist file implies that.

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Sorry, only registered users may post in this forum.

Click here to login