Welcome! Log In Create A New Profile

Advanced

Jucy 0.83 not starting

Posted by gummbah1 
Jucy 0.83 not starting
March 29, 2010 04:56PM
Hi,

Somehow when I start Jucy 0.83 (iMac), it shows the Jucy picture/logo for a while, but then it closes without any message.
I did not have this problem with 0.82. I have also tried 0.81 again, and it works fine.
When I try at my Macbook it does start without problems, so it must be something on my iMac system (although 0.82 does start without problems....)
Any suggestions?

Cheers



Edited 1 time(s). Last edit at 03/29/2010 08:20PM by gummbah1.
Re: Jucy 0.83 not starting
March 29, 2010 08:21PM
Besides, auto-update is also not working. It gives me the following error. Could this be related to the fact that 0.83 is not starting up? Apparently something cannot be uninstalled:

An error occurred while unconfiguring the items to uninstall
session context wassad smileyprofile=profile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Unconfigure, operand=[R]toolingeu.jucy.product1.product.config.cocoa.macosx.x86_64 0.81.0 --> null, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.SetProgramPropertyAction).
Error while loading manipulator.
Error while loading manipulator.
Re: Jucy 0.83 not starting
March 29, 2010 08:38PM
Ok, I tried creating a new user account on the iMac and then launch Jucy 0,83.
That works fine.
So it seems there is still something in place from a previous Jucy that was not uninstalled, and is now causing problems.
Where does Jucy store its preferences, cache, etc and how can I delete them?

Cheers
Re: Jucy 0.83 not starting
March 29, 2010 08:52PM
Ah got it, had to trash the .uc directory which is hidden in ~
Re: Jucy 0.83 not starting
March 29, 2010 11:12PM
though that is really bad ...

I hope other mac user don't experience the same problems...

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: Jucy 0.83 not starting
March 30, 2010 02:47AM
im getting

An error occurred while unconfiguring the items to uninstall
session context wassad smileyprofile=profile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Unconfigure, operand=[R]toolingeu.jucy.product1.product.config.cocoa.macosx.x86_64 0.82.0 --> null, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.SetProgramPropertyAction).
Error while loading manipulator.
Error while loading manipulator.

so im gonna just install from scratch.

the last update didnt work either sad smiley
Re: Jucy 0.83 not starting
March 30, 2010 02:51AM
I am not sure totally what is the reason for all this...


Currently I am guessing that this is due to the corrupted ini files some of the last versions had ...
though I am not sure..

I did not run into any problems updating though I had a corrected ini file..

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: Jucy 0.83 not starting
April 07, 2010 04:56PM
Potential problem that migh occur and cause jucy to be unable to start:

If Jucy wasn't shut down properly when it was updated to 0.83 version that database could be left in some ruckus and newer DB will only be able to open if the old DB is fine

so if you want to fix this and not just rehash your files (and readd your favusers)

there is 4 steps to do

1. get jucy 0.82 (downloads page -> versions)
2. start up jucy 0.82 and close it again properly
3. go to C:\Users\<username>\UC\db (or on unix its ~/.UC/db)
and delete all files starting with jucydb ...
4. start up 0.83 again
(0.83 copys db over first before trying to update now this copy has to be deleted for 0.83 trying again to update the db to current version)

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Re: Jucy 0.83 not starting
August 08, 2013 01:25AM
This seems to be the same problems that I am having with Jucy Ver 0.86 and OSX Mountain lion 10.8.4 on my Imac.
I presume that I also follow the last post.
Re: Jucy 0.83 not starting
August 08, 2013 09:48AM
To verify if you have some database corruption problem, you could move the ~/.UC/db directory somewhere else and check if the problem persists. Jucy should then start up and create a new fresh db.
This helps if your database got corrupted. The above described steps are only useful if the database was not properly closed/ slightly corrupted, but repairable. That kind of repair would happen automatically, except if there was a client version update that lead to a Jucy version with a different db.

So I am afraid you will have to delete your whole ~/.UC/db directory to get rid of the problem

------------------------------------------------------------------------
Freedom is a new religion, the religion of our time.
- Heinrich Heine
Sorry, only registered users may post in this forum.

Click here to login